Current Position:Home > TDS3054 VISA HTTP

TDS3054 VISA HTTP

Update:11-30Source: network consolidation
Advertisement
Hello,
I am trying to talk to s TDS3054 scope via ethernet and VISA.  TCPIP is configured correctly and the scope shows up in the browser.
However, when using MAX I see it and bring up the VISA panel and it will respond to sets and gets but when I try to do a Basic I/O read
I get an error BFFFF0015 and the message:
505 HTTP Version not supported.
Expected HTTP/1.1, received 0;DESE
Also, all of the NI example vi's get the same error.
Any clues?
Solved!
Go to Solution.

The Best Answer

Advertisement
LanlLabRat:
Let me ask a few questions for clarification.
1. It sounds like the problem is created when trying to perform something similar to Figure 6 of this tutorial:
http://zone.ni.com/devzone/cda/tut/p/id/3971. Is that correct? Or are you using a program other than
LabVIEW or other method to do your "basic i/o"?
2. Can you tell me what operating system you are using, version of VISA, and version of LabVIEW (if
applicable)? You can find your VISA version in MAX by expanding the "My System" tab, the expanding
the "Software" tab, and locating the numbers after "NI-VISA." For example, my version is 5.0.3.
3. If you are using LabVIEW, can you execute a VISA Find Resource.vi with an indicator wired to it to see if
LabVIEW can recognize your device?
I look forward to hearing back from you.
Thanks!
Tori W.
National Instruments