Current Position:Home > Java version for PI 7.0

Java version for PI 7.0

Update:10-11Source: network consolidation
Advertisement
Hi all,
Our PI 7.0 is running on JVM 1.4.2_21 over Windows Server 2008.  For our desktop upgrade from XP to Win7, I had tested on PC to launch Integration Repository (design) and Integration Directory (Config):
Success:
- Win XP with JRE 1.4.2
- Win7 Java 5 with JRE 1.5.0
Fail: Unable to launch the application (Error: Could not verify signing in resource)
- Win7 Java 6 with JRE 1.6.0 and 1.5.0
- Win7 Java 7 with JRE 1.6.0 and 1.7.0
May I know is there any documentation mentioned about Java support on different PI version?
If we upgrade PI to 7.1, is it work fine with Win 7 Java 6 or higher?
Thanks in advance.

The Best Answer

Advertisement
I did not have success by using java 6 to load the Integration builder for PI version 7.0 . The OS version is not a matter of concern here. You can run PI on any OS that can  run JAVA. 
You can specify/point  the java webstart configuration  "javaws" or "javacp" to use the an older version of Java, even if you have installed java 6 installed.
Let us know if you still have any issue ..