Current Position:Home > IE unable to connect to Oracle HTTP Server v10.1.2 with SSL

IE unable to connect to Oracle HTTP Server v10.1.2 with SSL

Update:12-10Source: network consolidation
Advertisement
Hi,
I configured OHS with SSL to run APEX applications.
This configuration can be run from Mozilla browsers and Opera, but not from Internet Explorer.
I suspect that IE doesn't support 256-bit encryption, as both browser above support it. So I set several combination of SSL Cipher Suite in ssl.conf. I also set IE to use TLS v1, SSLv2, and SSLv3. But this doesn't show any results. I also found that several sites which has 256 bit encryption (read the information from Mozilla and Opera browser) can also be opened by IE (read as 128 bit encryption). So I guess the encryption is not the problem, and I move on to the Apache error_log files.
What I found from Apache's error_log.xxxx is
[error] mod_ossl: SSL call to NZ function nzos_Handshake failed with error 29014 (server ---.---.com:4443, client --.--.--.--)
[error] mod_ossl: Unknown error
[error] mod_ossl: SSL call to NZ function nzos_Handshake failed with error 28864 (server ---.---.com:4443, client --.--.--.--)
[error] mod_ossl: SSL IO error [Hint: the client stop the connection unexpectedly]
So I looked in the Metalink and found Note:312041.1 and applied patch 4960210 and restart the server. But now it wouldn't start at all, despite that all configuration files were not changed.
Any help would be greatly appreciated.
Regards,
Aulia Bismar

The Best Answer

Advertisement
You can use any PKCS#12 file with OHS if it includes the complete private key and certificate chain. With Oracle Wallet Manager (owm) you could also create a private key, import it, import the CA certificate as trusted certificate, create a certificate request for the private key, get the certificate response from the CA and import this.
If you use an unsual CA, ie cacert.org, you must import the CA root certificate as a trusted server certificate for IE.
--olaf                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
  • IE unable to connect to Oracle HTTP Server v10.1.2 with SSL Update:12-10

    Hi, I configured OHS with SSL to run APEX applications. This configuration can be run from Mozilla browsers and Opera, but not from Internet Explorer. I suspect that IE doesn't support 256-bit encryption, as both browser above support it. So I set se

  • Unable to connect to Oracle 11g server using instantclient_11_1 in AIX Update:11-30

    Hi, I downloaded instantclient-basic-11.1.0.7.0-aix-ppc64.zip from oracle site and used the same for connection to 11g server for testing my application on AIX 5.3 machine. I am also using easysoft driver for the connection. But I am uhnable to conne

  • Unable to connect to Oracle Weblogic Administration Server Update:11-30

    Hi Folks, As part of installation steps, I am facing error with " Unable to connect to Oracle Weblogic Administration Server" Below is AdminServer Log, So please guide me reolving this impending issue. ####<12 Jun, 2014 2:46:01 PM IST> <

  • JMS - Unable to connect to a remote server Update:10-11

    Hi All I am trying to point my WL7.0 to a JMS QUEUE on ORACLE FUSION WL10.3 I am getting the following error message on myserver.log: (I deleted the port and ip) <Unable to connect to a remote server on address ### and port ### with protocol t3. The

  • Possible workaround for: Launch Debugger Error "Unable to connect to the RDS server" Update:10-11

    I do not yet have a reproducible case for this. *Sometimes* ColdFusion Builder throws the "Unable to connect to the RDS server" error, when attempting to start a debug session against a remote server. However, "RDS Dataview" and "