Current Position:Home > HTTP_Server when starting OPMN.

HTTP_Server when starting OPMN.

Update:12-10Source: network consolidation
Advertisement
Hi,
I am encountering the following error while trying to start the opmn :
C:\OraHome_2\oracleas_mid4b2b\opmn\bin>opmnctl shutdown
opmnctl: shutting down opmn and all managed processes...
C:\OraHome_2\oracleas_mid4b2b\opmn\bin>opmnctl startall
opmnctl: starting opmn and all managed processes...
================================================================================
opmn id=PUNITP75966D:6201
5 of 6 processes started.
ias-instance id=oracleas_mid4b2b.punitp75966d.ad.infosys.com
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
ias-component/process-type/process-set:
HTTP_Server/HTTP_Server/HTTP_Server
Error
--> Process (pid=1816)
time out while waiting for a managed process to start
Log:
C:\OraHome_2\oracleas_mid4b2b\opmn\logs\HTTP_Server~1
On the console, HTTP_Server has a status of "unavailable".
I tried shutting down all services from services.msc and restarting the machine. Still the HTTP_Server doesn't come up. I also checked the <ORA-HOME>/opmn/logs
08/11/14 11:24:04 Start process
[Fri Nov 14 11:24:04 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Nov 14 11:24:04 2008] [error] mod_ossl: Init: SSL call to NZ function nzos_OpenWallet failed with error 28759 (Server PUNITP75966D.ad.infosys.com:443, wallet file:C:\\OraHome_2\\oracleas_mid4b2b\\Apache\\Apache\\conf\\ssl.wlt\\default)
[Fri Nov 14 11:24:04 2008] [error] mod_ossl: Failed to open the wallet [Hint: incorrect path, incorrect password, bad wallet, ...]
Error: Failed to open the wallet [Hint: incorrect path, incorrect password, bad wallet, ...] (Server PUNITP75966D.ad.infosys.com:443, wallet file:C:\OraHome_2\oracleas_mid4b2b\Apache\Apache\conf\ssl.wlt\default)
08/11/14 11:51:20 Start process
[Fri Nov 14 11:51:23 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/14 12:10:25 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/14 12:20:53 Start process
08/11/14 18:42:32 Stop process
08/11/14 18:45:15 Start process
[Fri Nov 14 18:45:25 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/14 21:10:25 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/14 22:09:37 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/14 22:57:44 Start process
08/11/17 08:23:43 Start process
[Mon Nov 17 08:23:56 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 08:59:10 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 09:02:06 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 09:27:27 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 10:05:13 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 10:19:34 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 10:27:00 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 10:33:16 Start process
08/11/17 10:35:15 Stop process
08/11/17 10:55:09 Start process
[Mon Nov 17 10:55:24 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 11:40:49 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 12:22:27 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 12:43:11 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 12:59:27 Start process
08/11/17 13:01:26 Stop process
08/11/17 13:07:31 Start process
[Mon Nov 17 13:07:48 2008] [warn] pid file c:/orahome_2/oracleas_mid4b2b/apache/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 13:15:49 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
08/11/17 14:00:40 Start process
Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server running...
Can this error occur due to any changes while enabling SSL in opmn.xml or while specifying the wallet location in tip.properties?
MLR #5 Patch has been installed on B2B
Thanks & Regards,
Suhas.

The Best Answer

Advertisement
Please the wallet location specified in the Apache SSL configuration holds the wallet. File to look for "$ORACLE_HOME/Apache/Apache/conf/ssl.conf".
Look for the directory name configured against "SSLWallet" and the directory should contain valid ewallet.p12.
Sample installation in my box,
SSLWallet file:C:\Oracle10g\midtier2\Apache\Apache\conf\ssl.wlt\default
HTH.
Regards,
Sinkar
[From Ramesh Team]
  • HTTP_Server when starting OPMN. Update:12-10

    Hi, I am encountering the following error while trying to start the opmn : C:\OraHome_2\oracleas_mid4b2b\opmn\bin>opmnctl shutdown opmnctl: shutting down opmn and all managed processes... C:\OraHome_2\oracleas_mid4b2b\opmn\bin>opmnctl startall opmnc

  • Oracle HTTP Server : opmn issue Update:11-30

    Hi , i am currently facing this issue . Kindly advice . The error is listed below . C:\oracle\OraHttp\opmn\bin>opmnctl status Processes in Instance: standalone ----------------------------------------------+--------- ias-component | process-type | pi

  • Opmn configuration asistant failed Update:11-30

    I installed ORACLE AS 10.1.3.0 on RHEL 4. I had installed oracle 10.2.0.1 database and 10.1.2 DS on the same machine. At the last point of installation,the opmn configuration assistant failed. This is what the install.log files says: Invalid Exit Cod

  • My Oracle AS HTTP_Server cannot start now ! Update:11-30

    I use command './opmnctl startall' to start My My Oracle AS Server, But it didn't work now. step 1 $ ./opmnctl status Processes in Instance: ias.c.abc.net --------------------------------------------------------------+--------- ias-component | proces

  • Error Facing in HTTP_Server Update:11-30

    Hi every one, pls help me out regarding below problem. I am facing this problem during startup of HTTP_Server opmnctl: starting opmn and all managed processes... ================================================================================ opmn id

  • Opmn: HTTP server down Update:11-30

    my opmn is up and running but some parameters are down. >./opmnctl status Processes in Instance: ias1012.dba3.oretail.com -------------------+--------------------+---------+--------- ias-component      | process-type       |     pid      | status ---

  • Not able to start OEM Update:10-11

    Hi, I have installed Orcle grid control10.2.0.1 on node 1.Its a 11gr2 rac database. But i am not able to start OEM. [[email protected] bin]$ ./opmnctl status Processes in Instance: EnterpriseManager0.rac1.raczone.com -------------------+-------------------

  • Oracle 10.2.0 DB installation problem on Linux RedHat 4 Update:10-11

    When I install Oracle 10g release 2 database on my Linux RedHat 4 platform, I got the following error message (from action log file): INFO: /u01/app/oracle/product/10.2.0/db_1/bin/genorasdksh: Failed to link liborasdkbase.so.10.2 INFO: make: *** [lib

  • HTML DB 10g installation problem on linux HTTP-503 ORA-604 Update:10-11

    I have a problem after the installation of HTML DB from the linux 10g R2 companion image. I installed HTML DB and HTTP server in one go, on an new system that only has the default orcl database installed. I run Red Hat enterprise linux on a x86_64 sy

  • HTTP Server Doesn't Start after install Update:10-11

    I just completed an install of the 10.1.3.1 Oracle App Server. It indicated that the install was successful. I can see in the log the BPEL Manager deploying in the default domain, but I do not see any reference to the HTTP server. Also, when I do a *