Current Position:Home > HH3 broadband not working on Desktop PC

HH3 broadband not working on Desktop PC

Update:10-11Source: network consolidation
Advertisement
Hi,
BT have just sent me a Home Hub 3 to upgrade from my HH 1.5. I have connected it up fine, the wireless works and it work when i connect it to my BT work laptop via ethernet (I work for BT). However when i plug the ethernet into my Dell desktop PC i cant get a broadband connection (normal, not infinity).
My old HH 1.5 works fine on all 3 devices.  
Are there some settings on my Desktop PC that i need to change for HH3? Or could there be some other problem?
Thanks!
Solved!
Go to Solution.

The Best Answer

Advertisement
have you updated the driver for your network card from the manufacturers website and don't rely on windows update
If you like a post, or want to say thanks for a helpful answer, please click on the Ratings star on the left-hand side of the post.
If someone answers your question correctly please let other members know by clicking on ’Mark as Accepted Solution’.
  • HH3 broadband not working on Desktop PC Update:10-11

    Hi, BT have just sent me a Home Hub 3 to upgrade from my HH 1.5. I have connected it up fine, the wireless works and it work when i connect it to my BT work laptop via ethernet (I work for BT). However when i plug the ethernet into my Dell desktop PC

  • Broadband sharing from my desktop pc to my ibook Update:11-30

    i have a desktop pc at home which has a broadband connection which i want to share with my ibook wirelessly at the same time, so i can have the ibook use the internet wirelessly and the desktop directly connected to teh broadband while both being abl

  • HH3 Broadband blue light not working with Power Sa... Update:11-30

    Had a BT engineer here today to do a line check and DLM reset when he noticed the blue lights were out, so I told him they were disabled in the powersave mode via the HH Manager at that time.It wasn't till he'd gone I realised he meant the Broadband

  • Unable to connect more than one device Update:10-11

    Hi. We have copper Broadband with a fairly decent speed (13MB) and a HH3. I run a desktop PC for general internet access but my wife uses an iPad and is always downloading films, music etc. We also have a BT Vision box which is connected via Ethernet

  • Issues with Infinity - Connection Speed & Other Pr... Update:10-11

    Hi all, I had Infinity installed on 2nd November.  Besides some issues with BT mixing up delivery addresses the installation by Kelly Comms went smoothly, and was setup within 45 mins. Initial speeds were very good, achieving 74Mb/s Down & 18Mb/s Up

  • Home Hub 3 orange light few times a day. Update:10-11

    hi at whits end and family not impressed got BT infinity a few weeks ago and ever since then the HH3 Broadband light goes orange and the only way to get it back to blue is to reset the openreach white modem. i have tried everything to get the Blue li

  • Connecting Macbook to internet Update:10-11

    This is more of a general computing question but any help would be greatly appreciated: I am considering buying a Macbook, what will i need to wirelessly connect it to the internet? I currently have a broadband connection to this desktop although it

  • Transferring Pics Phone to Computer Update:11-30

    I have too many pictures on my phone and would like to save them to my computer.  I have been trying to use a USB cable to transfer photos from my phone to my computer. I'm running vista.  The computer loaded drivers for the phone but doesn't see the

  • Upgrade ThinkPad W510 to Win 10 Update:11-30

     I want to try to update a 5 year old ThinkPad W510, which I have not really been using much, from Win 7 to Win 10. I don't yet see it in the compatability list yet so I am not sure whether it will be viable although hardware-wise it meets the Win 10

  • Homehub & Packet Loss Update:11-30

    I noticed over the past week my internet connection seemed glitchy, with pages occasionally not loading, frequent disconnects from programs/games and sporadic packet loss, which I tracked down to my LAN.  Pinging the homehub, could be fine for a few