Current Position:Home > Help with Apache plugin for WebLogic on HP-UX

Help with Apache plugin for WebLogic on HP-UX

Update:12-10Source: network consolidation
Advertisement
Hi,
I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache 1.3.19.21(port
8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening on port
9001, and I followed the instructions to configure apache and weblogic. However
when I do http://mymachine:8080/weblogic/portal/hello.jsp. I get unable to find
page.
weblogic is installed in /weblogic. The hello.jsp is located in /weblogic/myserver/public_html/portal/hello.jsp.
Apache is installed in /opt/apache.
The Apache httpd.conf file contains the following:
<Location /weblogic>
SetHandler weblogic-handler
PathTrim /weblogic
WebLogicHost localhost
WebLogicPort 9001
</Location>
What am I missing ? The error_log for Apache shows the following:
[Mon Nov 12 11:21:09 2001] [warn] Loaded DSO libexec/mod_wl.so uses plain Apache
1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI)
[Mon Nov 12 11:21:10 2001] [notice] Apache/1.3.19 (Unix) PHP/4.0.4pl1 configured
-- resuming normal operations
[Mon Nov 12 11:21:32 2001] [notice] child pid 13248 exit signal Segmentation fau
lt (11)

The Best Answer

Advertisement
Well... there is a warning in the log file saying that it might crash - and then
it crashes. Check that you are running a supported platform, if you are, contact
BEA Support.
I would discourage the use of forwarding to 'localhost'.
Mike
"Niranjan Perera" mckesson.com wrote:
>
Hi,
I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache
1.3.19.21(port
8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening
on port
9001, and I followed the instructions to configure apache and weblogic.
However
when I do http://mymachine:8080/weblogic/portal/hello.jsp. I get unable
to find
page.
weblogic is installed in /weblogic. The hello.jsp is located in /weblogic/myserver/public_html/portal/hello.jsp.
Apache is installed in /opt/apache.
The Apache httpd.conf file contains the following:
<Location /weblogic>
SetHandler weblogic-handler
PathTrim /weblogic
WebLogicHost localhost
WebLogicPort 9001
</Location>
What am I missing ? The error_log for Apache shows the following:
[Mon Nov 12 11:21:09 2001] [warn] Loaded DSO libexec/mod_wl.so uses plain
Apache
1.3 API, this module might crash under EAPI! (please recompile it with
-DEAPI)
[Mon Nov 12 11:21:10 2001] [notice] Apache/1.3.19 (Unix) PHP/4.0.4pl1
configured
-- resuming normal operations
[Mon Nov 12 11:21:32 2001] [notice] child pid 13248 exit signal Segmentation
fau
lt (11)
  • Setup issues: Apache plugin for Weblogic Update:10-11

    Hi, I've spent couple of days without success trying to configure apache plugin for weblogic. I've configured in accordance with bea documentation and it works fine in windows environment but fails in Solaris 9. Plugin log file says it's processed th

  • JMX with apache plugin and weblogic Update:10-11

    Hy every body I use weblogic 9.1, throw apache plugin I try to get mbean with JMX, i have this error on the log of the server when I try to acces to a server by passing apache url into jmxConnector: java.lang.AssertionError: Assertion violated      a

  • Help with Apache plugin for WebLogic on HP-UX Update:12-10

    Hi, I am trying to get Weblogic 5.1(w/sp8) on HP-UX 11 talking to Apache 1.3.19.21(port 8080) also on HP-UX 11 ( both on same box ). I have WebLogic listening on port 9001, and I followed the instructions to configure apache and weblogic. However whe