Current Position:Home > Dual screens with x1600 mobility & open source driver

Dual screens with x1600 mobility & open source driver

Update:10-11Source: network consolidation
Advertisement
Hi, I've been trying to get a dual screen setup with two truly independent screens (not the one giant screen that xrandr gives you), but I've been having some issues.  The hardware I'm attempting this on is my macbook pro 2.1 with a 1440x900 internal display and ati x1600 mobility, and a 1680x1050 apple cinema display connected with DVI.  Here is the xorg.conf that I've come up with after a bit of tinkering.
Section "ServerLayout"
Identifier "Xorg Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
# Additional fonts: Locale, Gimp, TTF...
# FontPath "/usr/share/lib/X11/fonts/latin2/75dpi"
# FontPath "/usr/share/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/latex-ttf-fonts"
FontPath "/usr/share/fonts/defoma/CID"
FontPath "/usr/share/fonts/defoma/TrueType"
FontPath "/usr/share/fonts/local"
EndSection
Section "Module"
Load "ddc" # ddc probing of monitor
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "bitmap" # bitmap-fonts
Load "type1"
Load "freetype"
Load "record"
Load "synaptics"
Load "drm" #from arch wiki
EndSection
Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
Option "DontZap" "off"
Option "Xinerama" "0"
EndSection
Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" ""
EndSection
Section "Monitor"
Identifier "Monitor0"
Option "DPMS" "true"
EndSection
Section "Monitor"
Identifier "Monitor1"
Option "DPMS" "true"
EndSection
Section "Device"
Identifier "Radeon0"
Driver "radeon"
Option "XAANoOffscreenPixmaps" "true" #Needed for aiglx, from arch wiki
Option "AGPMode" "8"
Option "AccelMethod" "EXA"
Screen 0
EndSection
Section "Device"
Identifier "Radeon1"
Driver "radeon"
Option "XAANoOffscreenPixmaps" "true" #Needed for aiglx, from arch wiki
Option "AGPMode" "8"
Option "AccelMethod" "EXA"
Screen 1
EndSection
Section "Screen"
Identifier "Screen0"
Device "Radeon0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Virtual 3120 1050
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Section "Screen"
Identifier "Screen1"
Device "Radeon1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Virtual 3120 1050
Modes "1440x900" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Section "DRI"
Mode 0666
EndSection
Section "Extensions"
Option "Composite" "true"
EndSection
Sorry the tabs are a little screwed up, but I think it's still easy enough to read.  When I start the xserver using this file the external monitor appears to be functioning properly, but the internal display is black.  Moving the mouse off to the right of the external display causes the cursor to appear on the internal display using the default X cursor theme.  The mouse then remains trapped on the internal monitor.  Other than displaying the cursor, the internal display seems to be non-functional.
If I comment out the Screen...1 line in the ServerLayout section I can get both monitors working with xrandr, but this causes other issues and is not what I want.  Does anybody know how I could get two real screen going?
Thanks!

The Best Answer

Advertisement
bump (I'm starting to think this VGA card just doesn't work with the driver )
  • Dual screens with x1600 mobility & open source driver Update:10-11

    Hi, I've been trying to get a dual screen setup with two truly independent screens (not the one giant screen that xrandr gives you), but I've been having some issues.  The hardware I'm attempting this on is my macbook pro 2.1 with a 1440x900 internal

  • [ATI open source driver, laptop] Screen not refreshing properly. Update:11-30

    Hi guys, I've been using ATI Catalyst driver and everything was working well until I decided to switch to open source driver. Now I have strange problem. My screen is not refreshing properly, I mean, for example I use Facebook and I decide to read so

  • Dual screen with radeon driver stopped working Update:11-30

    I've been using the xf86-video-ati or xf86-video-radeonhd drivers on my ATI 1950Pro card with a dual screen setup on two 22" widescreen Acer monitors for the last year and all of a sudden the dual display is not working anymore. I had not changed my

  • What options do I have if I want to set up a dual screen? Update:10-11

    I have a Thinkpad T400 with a ATI Radeon HD3470 card. I am running the latest Arch x86_64 with Fluxbox and the 9.4 Catalyst drivers. What is the easiest solution to set up a dual screen? Is there a way to do this without editing xorg.conf? Not that e

  • Any one help me with dual screen? Update:10-11

    I am trying to get my LCD monitor work, which is plugged in VGA. However, when i using "xrandr --output VGA --auto" to set it up, i get this failure "xrandr: cannot find crtc for output VGA" i am using intel graphic card, and the resul

  • Dual screen problems after last updates Update:11-30

    Hello everyone,      it was long time since our Arch gave me some problems, but then now I'm fighting furiously with dual screen configuration with new gnome. Let me explain. I upgraded the home PC that I hadn't update for months, so I updated more o

  • Dual Screen on IBM X60s [SOLVED] Update:11-30

    Hey Forum. I hopefully can get some of your smart guys/girls to help me with this - I have an IBM X60s with the following graphiccard: lshwd: 00:00.0 Host bridge: Intel Corp.|Mobile Memory Controller Hub (intel-agp) 00:02.0 VGA compatible controller:

  • [SOLVED] ATI, radeonhd, xrandr dual screen setup trouble Update:11-30

    Hi fellow archers, I'm trying to configure an external monitor on my Thinkpad T60p. Relevant Information: └─[~]$ lspci | grep ATI [T60p]-[21:32]-[Tue Aug 11] 01:00.0 VGA compatible controller: ATI Technologies Inc M56GL [Mobility FireGL V5200] I want

  • External monitor simply not working - including with external dock (dual screen) Update:10-11

    I can't get the external monitor (aka dual screen) to work on my T60 via the VGA port. My model is currently running Windows XP and has a ATI Radeon X1300 video card. I'm 6 months out of warantee (although this problem started while in warantee but I

  • X crashes on startup with AMD dual screen setup Update:10-11

    Ever since I bought my AMD Kaveri A10-7850K at the end of January last year I've been having trouble getting a dual screen setup to work properly. Initially I put this down to poor beta drivers, and as I had far too much going on to investigate the i