Current Position:Home > Configuring Apache HTTP Server with Oracle Weblogic Server plugin

Configuring Apache HTTP Server with Oracle Weblogic Server plugin

Update:10-11Source: network consolidation
Advertisement
Hello friends,
I have a scenario of OIM 9.1.0.2 on Oracle Application Server 11g and Weblogic Server Apache HTTP Server.
Oracle WebLogic Server is configured in cluster (node1 and node2), also use the Oracle Weblogic Server plugin for integration with Apache.
One of the tests is to lose one of the nodes for the apache plugin redirects the node that has less overhead.
When the mode is node1 and node2 stop start mode and try to access the management console of Oracle Identity Manager, the plugin sometimes redirects to the other active node, and on another occasion shows the oracle management console identity manager without the colors of the basic look and feel.
Deputy of the Apache HTTP Server log, do you expect your comments to solve this case?
*************************************************log****************************************************
Server Details are:
OrigHostInfo [192.168.1.200]
isOrigHostInfoDNS [0]
Host [192.168.1.200]
Port [7002]
SecurePort [7004]
Mon Jan 30 22:10:43 2012 <2600713279794431> Initializing lastIndex=0 for a list of length=1
Mon Jan 30 22:10:43 2012 <2600713279794431> initJVMID: Trying to locate Primary or Secondary using SrvrInfo with JVMID [-872106207]
Mon Jan 30 22:10:43 2012 <2600713279794431> initJVMID: Found Primary 192.168.1.200:7002:7004
Mon Jan 30 22:10:43 2012 <2600713279794431> INFO: Closing SSL context
Mon Jan 30 22:10:43 2012 <2600713279794431> .....internal request /bea_wls_internal/WLDummyInitJVMIDs.....processed
Mon Jan 30 22:10:43 2012 <2600713279794431> getPreferredFromCookie: Found 1 servers
Mon Jan 30 22:10:43 2012 <2600713279794431> attempt #0 out of a max of 5
Mon Jan 30 22:10:43 2012 <2600713279794431> trying connect to PRIMARY '192.168.1.200'/7002/7004
Mon Jan 30 22:10:43 2012 <2600713279794431> getPooledConn: No more connections in the pool for Host[192.168.1.200] Port[7002] SecurePort[7004]
Mon Jan 30 22:10:43 2012 <2600713279794431> New SSL URL: match = 0 oid = 22
Mon Jan 30 22:10:43 2012 <2600713279794431> Connect returns -1, and error no set to 150, msg 'Operation now in progress'
Mon Jan 30 22:10:43 2012 <2600713279794431> EINPROGRESS in connect() - selecting
Mon Jan 30 22:10:43 2012 <2600713279794431> Setting peerID for new SSL connection
Mon Jan 30 22:10:43 2012 <2600713279794431> 0ae2 0436 0000 1b5c ...6...\
Mon Jan 30 22:10:43 2012 <2600713279794431> Local Port of the socket is 39186
Mon Jan 30 22:10:43 2012 <2600713279794431> Remote Host 192.168.1.200 Remote Port 7004
Mon Jan 30 22:10:43 2012 <2600713279794431> created a new connection to preferred server '192.168.1.200/7004' for '/xlWebApp/images/spacer.gif', Local port:39186
Mon Jan 30 22:10:43 2012 <2600713279794431> INFO: CA certificate missing basicConstraints, validation failed
Mon Jan 30 22:10:43 2012 <2600713279794431> ERROR: SSLWrite failed
Mon Jan 30 22:10:43 2012 <2600713279794431> SEND failed (ret=-1) at 793 of file ../nsapi/URL.cpp
Mon Jan 30 22:10:43 2012 <2600713279794431> *******Exception type [WRITE_ERROR_TO_SERVER] raised at line 794 of ../nsapi/URL.cpp
Mon Jan 30 22:10:43 2012 <2600713279794431> Marking 192.168.1.200:7004 as bad
Mon Jan 30 22:10:43 2012 <2600713279794431> got exception in sendRequest phase: WRITE_ERROR_TO_SERVER [os error=0,  line 794 of ../nsapi/URL.cpp]: at line 3160
Mon Jan 30 22:10:43 2012 <2600713279794431> INFO: Closing SSL context
Mon Jan 30 22:10:43 2012 <2598413279794431>
================New Request: [GET /images/cab.gif HTTP/1.1] =================
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: SSL is configured
Mon Jan 30 22:10:43 2012 <2598413279794431> SSL Main Context not set. Calling InitSSL
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: SSL configured successfully
Mon Jan 30 22:10:43 2012 <2598413279794431> Using Uri /images/cab.gif
Mon Jan 30 22:10:43 2012 <2598413279794431> After trimming path: '/images/cab.gif'
Mon Jan 30 22:10:43 2012 <2598413279794431> adding prepend path: /xlWebApp/
Mon Jan 30 22:10:43 2012 <2598413279794431> The final request string is '/xlWebApp/images/cab.gif'
Mon Jan 30 22:10:43 2012 <2598413279794431> Host extracted from serverlist is [192.168.1.100]
Mon Jan 30 22:10:43 2012 <2598413279794431> Host extracted from serverlist is [192.168.1.200]
Mon Jan 30 22:10:43 2012 <2598413279794431> Initializing lastIndex=0 for a list of length=2
Mon Jan 30 22:10:43 2012 <2598413279794431> getListNode: created a new server node: id='192.168.1.100:7004,192.168.1.200:7004' server_name='OIMSERVER', port='443'
Mon Jan 30 22:10:43 2012 <2598413279794431> getPreferred: availcookie=[JSESSIONID=6RGCPnbTFRG7LBrTRpFnv1QLnQHkxkqr4pjGhhGJyrJWJ1rv86NK!-872106207!NONE]
Mon Jan 30 22:10:43 2012 <2598413279794431> Found cookie from cookie header: JSESSIONID=6RGCPnbTFRG7LBrTRpFnv1QLnQHkxkqr4pjGhhGJyrJWJ1rv86NK!-872106207!NONE
Mon Jan 30 22:10:43 2012 <2598413279794431> Parsing cookie JSESSIONID=6RGCPnbTFRG7LBrTRpFnv1QLnQHkxkqr4pjGhhGJyrJWJ1rv86NK!-872106207!NONE
Mon Jan 30 22:10:43 2012 <2598413279794431> getpreferredServersFromCookie: [-872106207!NONE]
Mon Jan 30 22:10:43 2012 <2598413279794431> primaryJVMID: [-872106207]
secondaryJVMID: [NONE]
Mon Jan 30 22:10:43 2012 <2598413279794431> No of JVMIDs found in cookie: 1
Mon Jan 30 22:10:43 2012 <2598413279794431> getPreferredFromCookie: Start Position is 0, listLen is 2
Mon Jan 30 22:10:43 2012 <2598413279794431> getPreferredFromCookie: Either JVMIDs not set or they are stale. Will try to get JVMIDs from WLS
Mon Jan 30 22:10:43 2012 <2598413279794431> initJVMID: Iterating SrvrList from position 0
Mon Jan 30 22:10:43 2012 <2598413279794431> ======internal request /bea_wls_internal/WLDummyInitJVMIDs======
initJVMID: Trying Host[192.168.1.100] Port[7004] SecurePort[7004] useSSL [1] ioTimeout [30] socketTimeout [2]
Mon Jan 30 22:10:43 2012 <2598413279794431> New SSL URL: match = 0 oid = 0
Mon Jan 30 22:10:43 2012 <2598413279794431> Connect returns -1, and error no set to 146, msg 'Connection refused'
Mon Jan 30 22:10:43 2012 <2598413279794431> Error connecting to host 192.168.1.100:7004
Mon Jan 30 22:10:43 2012 <2598413279794431> *******Exception type [CONNECTION_REFUSED] (Error connecting to host 192.168.1.100:7004 errno = 146) raised at line 1723 of ../nsapi/URL.cpp
Mon Jan 30 22:10:43 2012 <2598413279794431> initJVMID: Failed to retrieved JVMID for 192.168.1.100:7004:7004
Mon Jan 30 22:10:43 2012 <2598413279794431> initJVMID: Marked server as BAD
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: Closing SSL context
Mon Jan 30 22:10:43 2012 <2598413279794431> .....internal request /bea_wls_internal/WLDummyInitJVMIDs.....processed
Mon Jan 30 22:10:43 2012 <2598413279794431> ======internal request /bea_wls_internal/WLDummyInitJVMIDs======
initJVMID: Trying Host[192.168.1.200] Port[7004] SecurePort[7004] useSSL [1] ioTimeout [30] socketTimeout [2]
Mon Jan 30 22:10:43 2012 <2598413279794431> New SSL URL: match = 0 oid = 0
Mon Jan 30 22:10:43 2012 <2598413279794431> Connect returns -1, and error no set to 150, msg 'Operation now in progress'
Mon Jan 30 22:10:43 2012 <2598413279794431> EINPROGRESS in connect() - selecting
Mon Jan 30 22:10:43 2012 <2598413279794431> Setting peerID for new SSL connection
Mon Jan 30 22:10:43 2012 <2598413279794431> 0ae2 0436 0000 1b5c ...6...\
Mon Jan 30 22:10:43 2012 <2598413279794431> Local Port of the socket is 39188
Mon Jan 30 22:10:43 2012 <2598413279794431> Remote Host 192.168.1.200 Remote Port 7004
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: Certificate validation succeeded
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: Negotiated to cipher: 3
Mon Jan 30 22:10:43 2012 <2598413279794431> SSLWrite sent 171
Mon Jan 30 22:10:43 2012 <2598413279794431> SSLWrite completed, sent 171
Mon Jan 30 22:10:43 2012 <2598413279794431> Reader::fill() SSLRead returned: 0 290
Mon Jan 30 22:10:43 2012 <2598413279794431> URL::parseHeaders: CompleteStatusLine set to [HTTP/1.1 404 Not Found]
Mon Jan 30 22:10:43 2012 <2598413279794431> URL::parseHeaders: StatusLine set to [404 Not Found]
Mon Jan 30 22:10:43 2012 <2598413279794431> parsed all headers OK
Mon Jan 30 22:10:43 2012 <2598413279794431> Parsing cluster list: -872106207!182584374!7002!7004
Mon Jan 30 22:10:43 2012 <2598413279794431> parseJVMID: Parsing JVMID '-872106207!182584374!7002!7004'
Mon Jan 30 22:10:43 2012 <2598413279794431> parseJVMID: Actually parsing '-872106207!182584374!7002!7004'
Mon Jan 30 22:10:43 2012 <2598413279794431> ServerInfo struct for JVMID '-872106207' populated
Server Details are:
OrigHostInfo [192.168.1.200]
isOrigHostInfoDNS [0]
Host [192.168.1.200]
Port [7002]
SecurePort [7004]
Mon Jan 30 22:10:43 2012 <2598413279794431> Initializing lastIndex=0 for a list of length=1
Mon Jan 30 22:10:43 2012 <2598413279794431> initJVMID: Trying to locate Primary or Secondary using SrvrInfo with JVMID [-872106207]
Mon Jan 30 22:10:43 2012 <2598413279794431> initJVMID: Found Primary 192.168.1.200:7002:7004
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: Closing SSL context
Mon Jan 30 22:10:43 2012 <2598413279794431> .....internal request /bea_wls_internal/WLDummyInitJVMIDs.....processed
Mon Jan 30 22:10:43 2012 <2598413279794431> getPreferredFromCookie: Found 1 servers
Mon Jan 30 22:10:43 2012 <2598413279794431> attempt #0 out of a max of 5
Mon Jan 30 22:10:43 2012 <2598413279794431> trying connect to PRIMARY '192.168.1.200'/7002/7004
Mon Jan 30 22:10:43 2012 <2598413279794431> getPooledConn: No more connections in the pool for Host[192.168.1.200] Port[7002] SecurePort[7004]
Mon Jan 30 22:10:43 2012 <2598413279794431> New SSL URL: match = 0 oid = 22
Mon Jan 30 22:10:43 2012 <2598413279794431> Connect returns -1, and error no set to 150, msg 'Operation now in progress'
Mon Jan 30 22:10:43 2012 <2598413279794431> EINPROGRESS in connect() - selecting
Mon Jan 30 22:10:43 2012 <2598413279794431> Setting peerID for new SSL connection
Mon Jan 30 22:10:43 2012 <2598413279794431> 0ae2 0436 0000 1b5c ...6...\
Mon Jan 30 22:10:43 2012 <2598413279794431> Local Port of the socket is 39189
Mon Jan 30 22:10:43 2012 <2598413279794431> Remote Host 192.168.1.200 Remote Port 7004
Mon Jan 30 22:10:43 2012 <2598413279794431> created a new connection to preferred server '192.168.1.200/7004' for '/xlWebApp/images/cab.gif', Local port:39189
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: CA certificate missing basicConstraints, validation failed
Mon Jan 30 22:10:43 2012 <2598413279794431> ERROR: SSLWrite failed
Mon Jan 30 22:10:43 2012 <2598413279794431> SEND failed (ret=-1) at 793 of file ../nsapi/URL.cpp
Mon Jan 30 22:10:43 2012 <2598413279794431> *******Exception type [WRITE_ERROR_TO_SERVER] raised at line 794 of ../nsapi/URL.cpp
Mon Jan 30 22:10:43 2012 <2598413279794431> Marking 192.168.1.200:7004 as bad
Mon Jan 30 22:10:43 2012 <2598413279794431> got exception in sendRequest phase: WRITE_ERROR_TO_SERVER [os error=0,  line 794 of ../nsapi/URL.cpp]: at line 3160
Mon Jan 30 22:10:43 2012 <2598413279794431> INFO: Closing SSL context
Thanks

The Best Answer

Advertisement
"One of the tests is to lose one of the nodes for the apache plugin redirects the node that has less overhead."
Note that the plug-in does a round robin load balancing, for example, in the case of three server (1,2,3) it does 1-2-3-1-2-3-1...
with server 3 going down it does 1-2-1-2-1...
An example configuration (with SSL off) looks as follows:
LoadModule weblogic_module   "/home/oracle/weblogic12.1.1/apache/modules/mod_wl.so"
<IfModule weblogic_module>
     ConnectTimeoutSecs 10
     ConnectRetrySecs 2
     DebugConfigInfo ON
     WLSocketTimeoutSecs 2
     WLIOTimeoutSecs 300
     Idempotent ON
     FileCaching ON
     KeepAliveSecs 20
     KeepAliveEnabled ON
     DynamicServerList ON
     WLProxySSL OFF
</IfModule>
<Location /LoadTest6>
     SetHandler weblogic-handler
     WebLogicCluster 172.31.0.175:7002,172.31.0.113:7003
</Location>Also see the complete example here: http://middlewaremagic.com/weblogic/?p=7795
"the plugin sometimes redirects to the other active node"
This is somewhat strange, do you have session binding turned off?
"and on another occasion shows the oracle management console identity manager without the colors of the basic look and feel."
This could happen due to mime types (not really sure just a hunch). Here is a general story on this concept: https://developer.mozilla.org/en/Properly_Configuring_Server_MIME_Types
and the apache module: http://httpd.apache.org/docs/2.2/mod/mod_mime.html