Current Position:Home > CFFORM VALIDATIOn

CFFORM VALIDATIOn

Update:11-30Source: network consolidation
Advertisement
Help I am having a major issue. I have a cold fusion mx7
server that has a number of sites on it. I have the same script
running on two different domains on the same box. One site the form
validation works and the other it doesn't. What's can it be? Also,
it was all of a sudden. Yesterday, the form validation worked fine
on both sites. I also noticed another customer of mine who I did a
cold fusion site the form validation stopped working on his box
today as well. I know the form validation was working on all three
sites. What can it be? This is urgent!! PLEASE!!!:confused; I can
put a temporariy fix and add a virtual dir for that non working
site to the cfide folder but why should I all of a sudden have to
start doing that?

The Best Answer

Advertisement
Well I ran into exactly the same issue yesterday and have
been pulling my hair out ever since. Arrrg.
I found a tech note that explains this in detail:
www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_18653
I'm on a multi-homed hosting provider but you would have the
same issue with mutiple sites on your own machine.
I copied my CFIDE/scripts directory from my CF developers
edition to the root of my hosted site and it immediately worked.
You'll need to preserve the directory structure but I bet you don't
really needed anything but cfform.js and masks.js. View the source
on your browsed pages and you'll see these files.
  • CFMX 7 CFFORM Validation doesn't work in 7.0.1 Update:10-11

    We have code that's been running under CF5 and CF6.1 just fine, but when we moved it to CF7 all of the cfform validation stopped working (standard cfform w/ no additional custom javascript, just cfinput tags w/ required attributes). We updated the se

  • CFFORM VALIDATIOn Update:11-30

    Help I am having a major issue. I have a cold fusion mx7 server that has a number of sites on it. I have the same script running on two different domains on the same box. One site the form validation works and the other it doesn't. What's can it be?

  • Cfform validation issue Update:11-30

    I have a cfform with 5 tabs. I have input boxes and submit forms on each tab for processing different data. The problem is when I'm on any of the tabs and hit the submit button, the client side validation pops up telling me that "ALL" the fields

  • Cfinput validation is not working Update:10-11

    I have a CF8 cfform which contains several cfinput tags set to required.  If I submit the form without fillign otu those fields, I do get the popup message displaying the error message(s) but when I click ok on that popup, it still submits the form.

  • Form validation problems - help Update:11-30

    I am having serious problems getting the cfform validation properties to work properly. When i submit an empty form it will not perform the javascript even though most fields are required. when i did a view source in the window all of the js code is

  • Cflayout, cflayoutarea and cfform - can't use target _parent? Update:11-30

    CF9 - I'm using a cflayoutarea within cflayout, then inside of that I have a cfform for login. When I submit my cfform it loads my login page (submitted) inside of the cflayout window, which I don't want. I've tried using target _blank, _parent, etc

  • CFMail Tag Issue Update:10-11

    I have a form on my website that use the cfmail tag to send information collected from a form via email. I am no longer getting the email submitted from the form yet I'm also not getting an error and I haven't changed anything. I suspect it's a relay

  • Need to find _CF_checkCFForm Update:11-30

    At the beginning of each page with a form that CF renders, it puts a JS function called _CF_checkWhateverForm. I need to find where in the guts of ColdFusion it is creating this function. When it tries to put the cursor in the first failed validiatio

  • Spry validation and CFFORM Update:10-11

    I am using Spry validation on some of my forms and noticed that if I am using CFFORM, the validation works, but the form is still allowed to submit if the validation fails. If I change the cfform tags to regular form tags the validation works and the

  • CFFORM and validation widget Update:11-30

    if you use a cfform this normally overwrites the spry validation at submit. Call on your cfform the validate() function on submit action. You should have something like: if (Spry.Widget.Form.validate(form) == true).... On submit check if the validate