Current Position:Home > Can Web Start call earlier installed versions on client machine?

Can Web Start call earlier installed versions on client machine?

Update:10-11Source: network consolidation
Advertisement
Can Web Start invoke earlier installed versions of the
JRE on a client machine, without invoking a download?
I ask because I have tried to so, unsuccessfully,
using the versions attribute of the j2se element.
In the usenet thread 'Jar test, with 1.4 VM?',
Usenet Message ID:
[email protected]
http://groups.google.com/[email protected]m
(follow the Google link at the top, to the thread)
I was attempting to confirm that a Jar file I
was deploying, was 1.4 compatible.
The test failed, because despite that the (1)
user who attempted it had a working 1.4.2 install,
the JNLP file (which declared version='1.4'),
was prompting for a download. The user was
not prepared to do that, understandably -
that was exactly what I was trying to avoid
doing, myself.
Since then, I did further testing locally -
trying to get a 1.5 launch when my current
Java is 1.6 - I have a number of 1.5 versions.
No request for '1.5', '1.5.0_08' or '1.5*' worked
(OK - that last one was just a WAG*), every time
I was prompted for download (which also failed,
as an aside!).
What am I getting wrong?
Do I misunderstand the intent of the j2se element
finding earlier verions? Is it only versions that
were installed by web start?
Is my understanding of how to use the version
attribute, incorrect?
* Where are the detailed instructions on the
allowable forms of the version attribute?
Neither the spec. nor developers guide seem
to go into it in any detail. Some of the forms
I have seen around the forum were (AFAIR)..
<!-- Suggests 1.4 preferred? -->
version="1.4 1.5+"
<!-- Suggests 1.4 only? -->
version="1.4"
<!-- Suggests 1.4.2 preferred, if microversion
13+ is found, else 1.5+? -->
version="1.4.2_13+ 1.5+"FWIW - here is the JNLP I am currently using
for the test, it is 'live and public'..
<?xml version='1.0' encoding='UTF-8' ?>
<!--
If you see this message in your browser, it means the
browser is not correctly set up to handle the JNLP file
type, that launches Java applications within a secure
environment, that cannot access your computer, or data.
To get the browser (and PC) correctly set up to handle
this type of file, visit ..
  http://www.java.com/
..to install the free, secure, Java Plug-In made
by Sun Microsystems.
-->
<jnlp spec='1.0'
    codebase='http://www.athompson.info/family/'
    href='thompson-1.4.jnlp'>
  <information>
    <title>Thompson Family Genealogy</title>
    <vendor>Andrew Thompson</vendor>
    <description kind='one-line'>
      The ancestors of William Robert Ramshaw Thompson
    </description>
    <offline-allowed />
    <shortcut online='false'>
      <desktop/>
    </shortcut>
  </information>
  <resources>
    <j2se
      version="1.4"
      href="http://java.sun.com/products/autodl/j2se" />
    <jar href='genj-applet.jar' main='true' />
  </resources>
  <applet-desc
    main-class='genj.applet.Applet'
    name='genealogy'
    codebase='./index.html'
    width='300'
    height='170'
    >
      <param name='GEDCOM' value='thompson.ged' />
      <param name='ZIP' value='thompson.zip' />
  </applet-desc>
</jnlp>

The Best Answer

Advertisement
Using your tips, I was able to find the 1.5
JRE's listed in the Java control panel
(of an XP Pro box) and see they had no
checkmark for 'enabled'.
After enabling 1.5.0_08, I was successfully
able to launch the application (OK - applet
really) using the 1.5.0_08 JRE.
Thanks.
As an aside, I had to specify '1.5.0_08'
exactly to get that JRE. This is fine for
local testing, but sometimes it is handy
to ask others to help test via the web,
and it would be nice if I could make it less
specific (e.g. '1.5', to get any installed
and enabled JRE that is a 1.5 variant)
Do I understand wrong? Should that work,
to specify '1.5' and get a '1.5.0_08' JRE that
is installed and enabled?