Current Position:Home > Added a Northbound SNMP Trap Receiver in Cisco PI 1.3, but not getting traps

Added a Northbound SNMP Trap Receiver in Cisco PI 1.3, but not getting traps

Update:11-30Source: network consolidation
Advertisement
Hi;
I tried going into the Administration, System Settings, Notification Receivers menu and adding a receiver. The receiver was our  Zenoss 4.2.3 Resource Manager system. Zenoss has no problems  receiving traps from  IOS devices such as switches; that is routine for us. For example, we  see snmpTrap_Linkdown events from 2960s,etc.
However, even with all the possible events and severities checked in the PI GUI for the receiver, we did not get anything.
As a quick test I added my desktop computer as a receiver and ran Wireshark. Nothing comes through from Cisco PI. 
This is supposed to be UDP 162 stuff, so there ought not be a need for a handshake or need  to permit anything on the receiver side. I would expect to  see a total  fire-hose of traps after the receiver is added. But that reasoning conflicts with the need to set the SNMP Community string for the Notification Receiver...
I downloaded the logs from Cisco PI and grepped through all of them for the IPs & names of the test receivers, but found no messages.
Any idea what might be wrong? Do I need to restart something after adding the receiver?
I did notice that even if I supply a ficticious IP and name for the receiver, after it is added the "Operational Status" still says "Up" ...
I sure wish NCS came with a better help system - I can't find anything in the Cisco config guides that explains what a "Northbound" receiver is.
So confused,
Steve

The Best Answer

Advertisement
Hi Matt, thanks for taking the time to reply.
>> Not sure why you are trying to do this with PI, this is really more of an ISE function
We don't have ISE and won't be getting it ... still trying to afford the > $100K for PI licenses. Our Content Filter vendor suggested using PI.
>>Is PI set to forward traps for client authentication?
I have all traps and severities checked. Not sure last week nothing showed up in Wireshark. Today I am seeing some UDP info from PI hitting my test workstation. However, when I associate and dissassociate my laptop, nothing comes through. Most of what I see are rogue notifications.
>> Are the controllers that PI is managing also set to forward the same traps?
In Configure,Controllers, , Management, TrapControl, all possible boxes are checked.
>> Is PI configured correctly to forward the traps you want?
Please see answer above.
>> Does your content filter have the right MIBs to decipher the traps correctly?
The content filter vendor says they will customize their software as needed, but the first step is to see traps getting forwarded, and right now, it appeards that PI is not forwarding what I would expect from the GUI settings. Let's worry about MIB stuff after we are getting the raw trap data.
Thanks,
Steve
Message was edited by: Stephen Crye, elaborated & provided latest info.
  • Added a Northbound SNMP Trap Receiver in Cisco PI 1.3, but not getting traps Update:11-30

    Hi; I tried going into the Administration, System Settings, Notification Receivers menu and adding a receiver. The receiver was our  Zenoss 4.2.3 Resource Manager system. Zenoss has no problems  receiving traps from  IOS devices such as switches; tha

  • SNMP traps from Cisco 4404 Update:11-30

    I have a Cisco 4404 WLC that sends its system logs to a syslog server (kiwicat), but I'm interested in getting the snmp traps sent over there as well.  I've configured the syslog server to accept the snmp on the right ports and I've confirmed that th

  • Cisco WLC 5508 not sending SNMP Traps Update:11-30

    Hello Everyone. I'm having a weird error on our WLC environment. We have an HA with two cisco WLC 5508 and i cannot get SNMP Traps working on a Windows PC running Kiwi Syslog server (free ed.). I can receive correctly Syslog messages, but not traps.

  • How to enable the "SNMP TRAP" Funcation in Prime Infrasructure 2.0 for receiveing the Third Party Device's SNMP TRAP Update:11-30

    I already uploaded the third party device's MIB to PI2.0,  but could not recive the third party device's SNMP TRAP properly . what do I need check for the PI ? or what do I need to setup for the PI? ThanksDuplicate post of : https://supportforums.cis

  • Anm 4.1 support for receiving snmp traps from CSS / ACE Update:11-30

    Hi Does anyone have an ANM 4.1 installation that is accepting snmp traps from their CSSes / ACEs? If I configure CSSes / ACEs to send snmp v1 traps to anm, they never appear in the Monitor -> Events view. I've tried both the ANM 4.1 Virtual Appliance

  • Configuring SNMP Trap receiver on AIP-SSM sensor Update:11-30

    I receive the following error message from my ASA5520 firewall when attempting to forward SNMP traps from my AIP-SSM20 sensor to a server on my Inside interface that is configured to receive SNMP traps: ASA-4-418001: Through-the-device packet to/from

  • How view snmp Traps CISCO PRIME 1.2 Update:11-30

                       It is posible to view snmp Traps from WLC to CISCO Prime ?? How ?Hi Steve : I need to view the traps which are generated in the Controller, I need to view that in the Cisco Prime Infractructure. I´ve configured Communities in WLC w

  • Questions on Receiving SNMP Traps Update:10-11

    Hi: - I have more questions on receiving SNMP traps: 1) the OEM plug-in can receive traps now, but when I click the metric, I see: Error getting data for target test20. Exception: ORA-20216: ORA-06512: at "SYSMAN.EMD_MNTR", line 817 ORA-01403: n

  • Which OEM Plug-In receives SNMP traps ? Update:11-30

    Hi: - Could someone please tell which existing OEM plug-ins are able to receive SNMP traps? - I want to download these plug-ins and test my agent for SNMP trap reception. Thanks JohnThese plug-ins have logic to receive SNMP traps: EMC Celerra EMC CLA

  • Cisco Prime Infrastructure 1.4 SNMP Traps are not converted into Alarms Update:11-30

    Hi everybody, I just configured SNMP Traps on a Cisco Catalyst 3750-x to send to our Cisco Prime Infrastructure 1.4 Appliance. Now I forced the Switch to send some traps (Power off a Power Supply, Interface errdisable). The only events I see in Alarm