Current Position:Home > Adapter engine missing in the comm channal configuration

Adapter engine missing in the comm channal configuration

Update:10-11Source: network consolidation
Advertisement
Hi Experts,
I am creating a File-IDOC scenario. While doing the configuration for the sender communication channel for file adpter the integration server is missing in the adapter engine drop down.
But when i checked for other adapter type like Idoc and Http adapter, the Integration channel is available in the adapter engine drop down(only for these two apater type only, for other adapters also i am not getting the integration server).
Can anyone help me regarding this, how to resolve this problem.
Any SAPnotes or blogs for that.
Help will be apprediated and rewarded as well.
Thanks
Manisha

The Best Answer

Advertisement
hi manisha,
check the previous reply....the blog is nice
and also check the note 764176
check below
1. Open the "Content Maintenance" view under "Administration" in the SLD editing interface. (in 7.10: the view "CIM Instances".) Select "XI Integration Server" from the drop-down menu and navigate to the associations of the integration server. Select the "XI Integration Server Logical Identity" association and delete the association by pressing the 'Remove' button.
2. Switch to "Home" in the "Technical Landscape" view, and select the "Exchange Infrastructure" technical system type there. (as of 7.10: "Process Integration".) Select all domains and XI components for the host and delete these by selecting them and pressing 'Remove'.
3. Start the J2EE server. After you restart the server, the XI components log on to the SLD again and create a new entity of the "XI Integration Server" class.
4. To register the directory and repository again, you must also log on to the two tools.
5. Under 'Technical Landscape' in the SLD, select the "Exchange Infrastructure" technical system type. (as of 7.10: "Process Integration") and check whether all XI components (Adapter Engine, Integration Directory, Integration Repository, Integration Server and Runtime Workbench/RWB) are logged on correctly. The Adapter Engine component may be missing. In this case, start the registration of the Adapter Engine as described in Note 1031321, step 2.
6. Change again to the administration interface --> Content Maintenance (7.10: "CIM Instances") to the associations of the XI integration server.
              Create a new association by pressing the 'New Association' button, select the "XI Sub-System viewed Application System" associations type here, and, in the next step, choose the BC system for the Integration Server. Save the association by selecting 'Associate'.
              Create a new association by pressing the 'New Association' button, select the "XI Integration Server Logical Identity" association type here, and, in the next step, choose the business system for the Integration Server. Save the association by selecting 'Associate'.
7. Under 'Technical Landscape' in the SLD, select the "Exchange Infrastructure" technical system type. (7.10: "Process Integration") and check whether the association to the application system is displayed there (in column "Application System", the business system on which the integration server runs should be displayed).
8. To make the changed associations known in the directory, the SLD temporary storage must be deleted in the directory. To do this, log on to the Integration Directory and select the 'Environment --> Delete temporary storage areas for SLD data' menu option.
reward  points if helpfull
regards
kummari
Edited by: kummari on Jul 10, 2008 8:42 AM
  • Adapter engine missing in the comm channal configuration Update:10-11

    Hi Experts, I am creating a File-IDOC scenario. While doing the configuration for the sender communication channel for file adpter the integration server is missing in the adapter engine drop down. But when i checked for other adapter type like Idoc

  • Configuration Steps for Decentralized Adapter Engine Update:10-11

    Hi all, What all configuration steps are required to make Adapter Engine as Decentralized AE. I have made required changes in SLD DataSupplier in Visual Administrator. what more configurations have to be done? On SAP XI Server and Decentralized Adapt

  • Error in Local J2EE Adapter Engine Update:10-11

    Hi All, We configured the J2ee Adapter engine and did the design and Configuration part also.but while testing the scenario it's giving error in SXMB_MONI as *<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>* *-

  • Not able to select Adapter engine with adapter configuration Update:10-11

    Hello, We've just installed new XI system (PI 7.0 SP7). When we want to configure an comm. channel adapter running on the central adapter (eg. RFC_adapter)engine. In the dropdown bo for the Adapter Engine No entry is available for selection. When loo

  • PI 7.11 - Configuration: Adapter Engines Not found Update:10-11

    Hi, We have a PI 7.11 System that is connected to a central SLD. There are also two PI 7.0 systems connected to this SLD. If i open a communicationChannel i get following message: Adapter Engines Not foundNo SLD elements of type SAP_XIAdapterFramewor

  • Adapter engine field blank in File Comm channel (Sender) Update:10-11

    Hi, I am not getting any value in drop-down list of adapter engine in file adapter communication channel.System is allowing me to save the comm channel but when I am trying to create sender agreement, system is giving me following error <b>Unable to

  • Installation and then Configuration of Plain J2se Adapter Engine Update:10-11

    Hi All, Actually we want to use JMS Adapter for that we had installed Plain J2SE Adapter Engine but after installing and following the initial steps of Adapter.pdf we are not able to access the Adapter Engine through URL.We are using the URL http://<

  • URL For J2SE Adapter Engine Configuration Update:10-11

    Hi All, I have to go for adapter configuration for that i need to go to Adapter Engine Configuration Screen. So can any one please tell me the URL for going to the particular screen. Regards, RahulHi rahul,   I think URL for J2SE adapter engine is ht

  • Configuration of JMS Adapter in Central Adapter Engine Update:10-11

    Hi all, I have configured Sender JMS Adapter in Central Adapter Engine with the following parameters: Adapter type : JMS Transport Protocol : WebSphere MQ (non-jms) Message Protocol : JMS1.x Adapter Engine : Integration Server Queue Connection Factor

  • Question about Integrated Configuration (Advanced Adapter Engine in PI 7.1) Update:10-11

    Hello, When you use Advanced Adapter Engine in PI 7.1 with Integrated Configuration scenario, it bypasses ABAP stack therefore you can't monitor processed message in SXMB_MONI.  Instead this message shows up only in RWB Adapter Engine message monitor